Как в ячейке эксель сделать выбор


Лучшие новости сайта

Как в ячейке эксель сделать выбор

Как в ячейке эксель сделать выбор

Как в ячейке эксель сделать выбор

Как в ячейке эксель сделать выбор

Сегодня мы рассмотрим функцию ЕСЛИ.

Функция ЕСЛИ часто используется в Excel для решения многих задач. Знать ее очень полезно. В данной статье мы попробуем рассказать про ее работу на простых примерах, достаточно один раз разобраться с конструкцией функцией ЕСЛИ и вы сможете применять ее и в самых сложных вариантах.

Если вам требуется использовать функцию ЕСЛИ несколько раз в одной формуле, то используйте .

Если вам необходима проверка условий большого количества однотипных ЕСЛИ, то возможно вам будет полезна статья про .

Функция ЕСЛИ проверяет, выполняется ли условие, и возвращает одно значение, если оно выполняется, и другое значение, если нет.

Синтаксис функции ЕСЛИ очень простой:

ЕСЛИ(лог_выражение; [значение_если_истина]; [значение_если_ложь])

лог_выражение – это любое значение или выражение, которое при вычислении дает значение ИСТИНА или ЛОЖЬ.

Что это значит?   Выражение при вычислении дает значение ИСТИНА если это выражение верно.

В этой части необходимо проверить на соответствие выражения.

Например:

=ЕСЛИ(А1=10; [значение_если_истина]; [значение_если_ложь])  - если А1 равно 10, то выражение  А1=10 даст значение ИСТИНА, а если не равно 10, то ЛОЖЬ

Другой пример

=ЕСЛИ(А1>30; [значение_если_истина]; [значение_если_ложь])  - если в ячейки А1 число больше 30, то А1>30 вернет ИСТИНА, а если меньше, то ЛОЖЬ

Еще пример

=ЕСЛИ(С1=”Да”; [значение_если_истина]; [значение_если_ложь])  - если в ячейки C1 содержится слово “Да” то выражение вернет значение ИСТИНА, а если нет, то С1=”Да” вернет ЛОЖЬ

Надеюсь с этим понятно, поехали дальше. Рассмотрим следующие компоненты функции ЕСЛИ

=ЕСЛИ(лог_выражение; [значение_если_истина]; [значение_если_ложь])

значение_если_истина, значение_если_ложь – как видно из их названия, это то что необходимо сделать в зависимости от того, что вернул лог выражения: ИСТИНА и ЛОЖЬ

Пример использования функции ЕСЛИ в Excel

Рассмотрим использование функции ЕСЛИ на практическом примере. У нас есть таблица заказов, которую мы использовали при рассмотрении работы . Нам необходимо заполнить столбец по заказам Ведер (ошибочно на картинке указано «Заказы Cтолов»), то есть необходимо выбрать только заказы с Ведрами. Это можно сделать различными способами,   но мы с вами будет использовать функцию ЕСЛИ, чтобы показать ее работу на примере. (см.рисунок)

Функция ЕСЛИ в Excel с примерами

Для решения поставленной задачи напишем формулу с использованием функции ЕСЛИ

=ЕСЛИ(A3="Ведро";D3;"-")

и нажмем Enter

Функция ЕСЛИ в Excel с примерами

Как вы смогли заметить аргументы функции ЕСЛИ разделены точкой с запятой.

Итак, первый аргумент (лог выражения) A3="Ведро" проверяет содержится ли в ячейке А3 слово «Ведро», если содержится, то выполняется второй аргумент функции ЕСЛИ (значение_если_истина), в нашем случае это D3 (т.е стоимость заказа),  если в ячейка А3 не равна слову «Ведро», то выполняется третий аргумент функции ЕСЛИ (значение_если_ложь), в нашем случае это «-» (т.е будет написано тире).

Таким образом, в ячейки E3 появится значение D3, т.е число 240.

Далее необходимо протянуть формулу вниз для остальных значений. Для этого необходимо выделить ячейку  Е3 и потянуть вниз за нижний правый угол (смотрите рисунок 3)

Функция ЕСЛИ в Excel с примерами

Итоговый результат работы функции ЕСЛИ вы можете посмотреть на рисунке 4.  Функцию ЕСЛИ можно использовать в очень многих ситуациях. Находить ошибки, находить уникальные значения в списке, использовать многократные проверки на выполнение условий. Разбор всех этих ждет вас впереди.

Если статья была Вам полезна, то будем благодарны, если Вы поделитесь ей со своими друзьями с помощью кнопок расположенных ниже.

Спасибо за внимание.


 


Источник: http://sirexcel.ru/priemi-excel/funkciya-esli-v-excel-s-primerami/



Как в ячейке эксель сделать выбор

Как в ячейке эксель сделать выбор

Как в ячейке эксель сделать выбор

Как в ячейке эксель сделать выбор

Как в ячейке эксель сделать выбор

Как в ячейке эксель сделать выбор

Как в ячейке эксель сделать выбор

Как в ячейке эксель сделать выбор